<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Ben Meehan, Derek Mullahy taken in USHL dispersal draft</title><link rel="stylesheet" href="https://www.hockeyjournal.com/wp-content/cache/min/2/6efb5a6e492529fe83cbbe04977af379.css" media="all" data-minify="1" />
	<meta name="description" content="Eight New England players were selected in Monday’s United States Hockey League Dispersal Draft." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Ben Meehan, Derek Mullahy taken in USHL dispersal draft" />
	<meta property="og:description" content="Eight New England players were selected in Monday’s United States Hockey League Dispersal Draft." />
	<meta property="og:url" content="https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/" />
	<meta property="og:site_name" content="New England Hockey Journal" />
	<meta property="article:published_time" content="2020-09-22T17:49:46+00:00" />
	<meta property="article:modified_time" content="2020-09-22T18:05:05+00:00" />
	<meta property="og:image" content="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg" />
	<meta property="og:image:width" content="775" />
	<meta property="og:image:height" content="475" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@JeffCoxSports" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.hockeyjournal.com/#organization","name":"Seamans Media Inc","url":"https://www.hockeyjournal.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/#logo","inLanguage":"en-US","url":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/logo.png","width":202,"height":74,"caption":"Seamans Media Inc"},"image":{"@id":"https://www.hockeyjournal.com/#logo"}},{"@type":"WebSite","@id":"https://www.hockeyjournal.com/#website","url":"https://www.hockeyjournal.com/","name":"New England Hockey Journal","description":"","publisher":{"@id":"https://www.hockeyjournal.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.hockeyjournal.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#primaryimage","inLanguage":"en-US","url":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg","width":775,"height":475,"caption":"UMass Lowell freshman defenseman Ben Meehan played last season in Cedar Rapids. (Rick Boots/RoughRiders)"},{"@type":"WebPage","@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#webpage","url":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/","name":"Ben Meehan, Derek Mullahy taken in USHL dispersal draft","isPartOf":{"@id":"https://www.hockeyjournal.com/#website"},"primaryImageOfPage":{"@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#primaryimage"},"datePublished":"2020-09-22T17:49:46+00:00","dateModified":"2020-09-22T18:05:05+00:00","description":"Eight New England players were selected in Monday\u2019s United States Hockey League Dispersal Draft.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/"]}]},{"@type":"Article","@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#article","isPartOf":{"@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#webpage"},"author":{"@id":"https://www.hockeyjournal.com/#/schema/person/c549c8e4ac80278fa049cc9e9d4331fa"},"headline":"Ben Meehan, Derek Mullahy among New Englanders taken in USHL dispersal draft","datePublished":"2020-09-22T17:49:46+00:00","dateModified":"2020-09-22T18:05:05+00:00","mainEntityOfPage":{"@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#webpage"},"publisher":{"@id":"https://www.hockeyjournal.com/#organization"},"image":{"@id":"https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/#primaryimage"},"keywords":"Alex Gagne,Ben Meehan,Cedar Rapids RoughRiders,D.J. Hart,Derek Mullahy,dispersal draft,Doug Grimes,Garrett Sundquist,Madison Capitols,Ryan McGuire,Stephen Davis,United States Hockey League,USHL","articleSection":"Featured,Juniors","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.hockeyjournal.com/#/schema/person/c549c8e4ac80278fa049cc9e9d4331fa","name":"Jeff Cox","image":{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1ddfa9e038bd481d56bb2b2b2918ec73?s=96&d=mm&r=g","caption":"Jeff Cox"},"description":"Jeff Cox covers today\u2019s prospects and tomorrow\u2019s pros. His coverage range includes midget, high school, prep, junior and colleges. He's based in the Greater Boston area. You can reach him at jcox@hockeyjournal.com.","sameAs":["https://twitter.com/JeffCoxSports"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="New England Hockey Journal &raquo; Feed" href="https://www.hockeyjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="New England Hockey Journal &raquo; Comments Feed" href="https://www.hockeyjournal.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	




<style id='supersideme-style-inline-css' type='text/css'>
nav,#nav,.nav-primary,.nav-secondary,.supersideme .site-header .secondary-toggle,.menu-toggle {display:none }.slide-nav-link,.ssme-search,.button.ssme-button.ssme-custom {display:block }.sidr {width:330px }.sidr.left {left:-330px }.sidr.right {right:-330px }.slide-nav-link {background-color:#fff;left:0;color:#050505;position:relative;width:auto }.sidr {background-color:#fff;color:#050505 }.sidr h3,.sidr h4,.sidr .widget,.sidr p {color:#050505 }.slide-nav-link:focus,.sidr:focus,.sidr a:focus,.menu-close:focus,.sub-menu-toggle:focus {outline:#050505 dotted 1px }.sidr a,.sidr a:focus,.sidr a:active,.sidr button,.sidr .sub-menu-toggle:before {color:#050505 }.search-me {color:#fff }.slide-nav-link:before,.search-me:before,.menu-close:before,.sidr .sub-menu-toggle:before,.ssme-search:before,.ssme-button:before {-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;display:inline-block;font-style:normal;font-variant:normal;font-weight:900;font-family:'Font Awesome 5 Free','FontAwesome';font-size:20px }.menu-close:before,.sidr .sub-menu-toggle:before {font-size:16px }.slide-nav-link:before {content:'\f0c9' }.slide-nav-link.menu-open:before {content:'\f0c9' }.sidr .menu-close:before {content:'\f00d' }.sidr .sub-menu-toggle:before {content:'\f107' }.sidr .sub-menu-toggle-open:before {content:'\f106' }.search-me:before {content:'\f002' }.ssme-search:before {content:'\f002' }
</style>




<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=4.4.1' type='text/css' media='only screen and (max-width: 768px)' />

<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>








<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.hockeyjournal.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>








<link rel='https://api.w.org/' href='https://www.hockeyjournal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.hockeyjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.hockeyjournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.hockeyjournal.com/?p=77216' />


	 <!-- Stream WordPress user activity plugin v3.5.1 -->
<style>.woocommerce-password-strength.short {color: #e2401c}.woocommerce-password-strength.bad {color: #e2401c}.woocommerce-password-strength.good {color: #3d9cd2}.woocommerce-password-strength.strong {color: #0f834d}.woocommerce-password-strength {display: inline-block;float: right;}.woocommerce-password-hint{display: none;}</style>         <style type="text/css">
             .site-header { background-color: #24305c; } 
			 .header-image .site-title a { background-image: url(https://cdn.seamansmedianetwork.com/wp-content/uploads/sites/2/2018/04/27190517/NEHockey-Journal_white-1.png)}
         </style>
             <style type="text/css" id="customizer-colors">
			 
			 /*Background color*/
			.site-header, .button, .site-header #slide-menu, .footer-widgets, .site-footer, .woocommerce #respond input#submit.alt, .woocommerce a.button.alt, .woocommerce button.button.alt, .woocommerce input.button.alt, .woocommerce #respond input#submit, .woocommerce a.button, .woocommerce button.button, .woocommerce input.button, .menu-close {  background-color: #24305c  !important; }
			 
			 /* Subscribe Heading */
			 .subscribe-heading { color: #24305c  !important; border-color: #24305c  !important; }
			 
			 /*A tag color*/
			.entry-tags a, .entry-content p a, .woocommerce-info::before { color: #24305c !important; }
			 
			/*hover color*/
			.featured-content .entry-title a:hover, .related-video h4 a:hover, .video-archive-link:hover,.entry-title a:hover, .entry-title a:focus, a.more-link:hover, .category-featured-content a:hover, .single-post-display-category:hover, .entry-tags a:hover, .archive-article-item .archive-article-title a:hover, .related-read-more:hover,  .entry-content p a:hover { color: #5888e8 !important; }
			 
			 
			/*text in buttons and background color*/
			.right-header-menu .menu .menu-item a .button, #slide-menu:before, .woocommerce #respond input#submit, .woocommerce a.button, .woocommerce button.button, .woocommerce input.button, .category-archive-title, .category-featured-content, .category-featured-content a, a.pdf-download, a.subscribe-button { color: #ffffff !important;}
			 
			/* Button Text Hover Color */
			button:hover, input:hover[type="button"], input:hover[type="reset"], input:hover[type="submit"], .button:hover, button:focus, input:focus[type="button"], input:focus[type="reset"], input:focus[type="submit"], .button:focus, .woocommerce a.button.alt:hover, .woocommerce button.button.alt:hover, .woocommerce input.button.alt:hover,.woocommerce a.button:hover, .woocommerce button.button:hover, .woocommerce input.button:hover { color: #ffffff !important;}
			 
			/*WooCommerce Price Color*/
			.woocommerce div.product p.price, .woocommerce div.product span.price, .woocommerce ul.products li.product .price {color: #24305c !important;}
			 
			/*Primary Border Color*/
			.single-post .entry-header, .related-articles h2, .home .site-inner .widgettitle a, #home-four section.featuredpost:last-of-type article:after,.single-video .season-title, .archive .season-title, .directory-listings .directory-entry .profile-image, .category-permalink, .woocommerce-info, #home-top .widgettitle span { border-color: #24305c !important;}
			 
			/*Secondary Border Color*/
			.video-archive-link, .woocommerce-message { border-color: #24305c !important; }
			 
			/*Secondary Link Color*/
			.video-archive-link, .woocommerce-message::before { color: #24305c !important;  }
			 
			/*Secondary Background Color*/
			#gated-content-cta .widget .gform_wrapper .gform_footer input, .woocommerce #login-widget-area a.button.subscribe-button {background-color: #24305c !important;}
			 
			 
         </style>
    <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '3296317370385606'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=3296317370385606&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->

<meta name="viewport" content="width=device-width, initial-scale=1"><link href="https://fonts.googleapis.com/css?family=Open+Sans:400,600|Roboto:400,500,700&#038;display=swap" rel="stylesheet"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-9005406006369011",
    enable_page_level_ads: true
  });
</script>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192-100x100.png" sizes="32x32" />
<link rel="icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" />
<meta name="msapplication-TileImage" content="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" />
		<style type="text/css" id="wp-custom-css">
			.archive .category-hero { background-color: #808080 !important}		</style>
		<style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- WooCommerce Google Analytics Integration -->
		
		<script type='text/javascript'>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script', '//www.google-analytics.com/analytics.js','ga');ga( 'create', 'UA-119829409-2', 'auto' );ga( 'require', 'linkid' );ga( 'set', 'anonymizeIp', true );
		ga( 'set', 'dimension1', 'no' );
ga( 'require', 'ecommerce', 'ecommerce.js');</script>
		<!-- /WooCommerce Google Analytics Integration --><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-77216 single-format-standard theme-genesis featured juniors no-js woocommerce-no-js membership-content access-restricted has-featured-image header-image header-full-width full-width-content genesis-breadcrumbs-hidden genesis-footer-widgets-visible">
		<div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.hockeyjournal.com/">New England Hockey Journal</a></p></div><div class="right-header-menu"><div class="menu-right-menu-container"><ul id="menu-right-menu" class="menu"><li id="menu-item-12" class="log-show menu-item menu-item-type-post_type menu-item-object-page menu-item-12"><a href="https://www.hockeyjournal.com/account/">Login</a></li>
<li id="menu-item-517" class="log-show menu-item menu-item-type-post_type menu-item-object-page menu-item-517"><a href="https://www.hockeyjournal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-96" class="log-hide menu-item menu-item-type-custom menu-item-object-custom menu-item-96"><a href="http://www.hockeyjournal.com/account/">Dashboard</a></li>
</ul></div></div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-77216 post type-post status-publish format-standard has-post-thumbnail category-featured category-juniors tag-alex-gagne tag-ben-meehan tag-cedar-rapids-roughriders tag-d-j-hart tag-derek-mullahy tag-dispersal-draft tag-doug-grimes tag-garrett-sundquist tag-madison-capitols tag-ryan-mcguire tag-stephen-davis tag-united-states-hockey-league tag-ushl access_level-premium-subscriber membership-content access-restricted entry gs-1 gs-odd gs-even gs-featured-content-entry" aria-label="Ben Meehan, Derek Mullahy among New Englanders taken in USHL dispersal draft"><header class="entry-header"><div class="subscribe-heading"><a href="/subscribe/">Subscribe</a></div><a class="single-post-display-category" href="https://www.hockeyjournal.com/category/juniors/">Juniors</a><h1 class="entry-title">Ben Meehan, Derek Mullahy among New Englanders taken in USHL dispersal draft</h1>
<div class="subheading"></div><p class="entry-meta"><div class="author-block"><span class="author-avatar"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/1ddfa9e038bd481d56bb2b2b2918ec73?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' data-lazy-src="https://secure.gravatar.com/avatar/1ddfa9e038bd481d56bb2b2b2918ec73?s=64&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/1ddfa9e038bd481d56bb2b2b2918ec73?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1ddfa9e038bd481d56bb2b2b2918ec73?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' /></noscript></span><div class="author-meta-block">By <a href="https://www.hockeyjournal.com/author/jeffcox/" itemprop="url" rel="author">Jeff Cox</a><time class="entry-time">September 22, 2020</time></div></div></p></header><div class="entry-content"><div class="single-wrap"><div class="article-featured-image"><img width="775" height="475" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20775%20475'%3E%3C/svg%3E" class="attachment-large size-large wp-post-image" alt="" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg 775w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-600x368.jpg 600w" data-lazy-sizes="(max-width: 775px) 100vw, 775px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg" /><noscript><img width="775" height="475" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg" class="attachment-large size-large wp-post-image" alt="" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC.jpg 775w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/ben-meehan-WEB-775-9.22.20-DC-600x368.jpg 600w" sizes="(max-width: 775px) 100vw, 775px" /></noscript><div class="single-image-caption">UMass Lowell freshman defenseman Ben Meehan played last season in Cedar Rapids. (Rick Boots/RoughRiders)</div></div><p>Eight New England players were selected in Monday’s United States Hockey League Dispersal Draft.</p>
<p>The USHL dispersal draft was for the purpose of moving players that were on the rosters and affiliate lists of the Cedar Rapids RoughRiders and Madison Capitols for the 2019-20 season. All players with junior hockey eligibility remaining for the 2020-21 season were eligible to be selected by other USHL member clubs. Cedar Rapids and Madison announced last week that they would sit out the 2020-21 season.</p>
<p>The league did not list an order of where players were selected in the dispersal draft. A few league teams opted to draft players that are reportedly going to be freshmen on a college hockey roster this season. There obviously is still some uncertainty with whether or not the college season will go off as currently planned, starting in November.</p>
</div><div class="sm-display-ad"><div class="sm-ad-disclaim">Advertisement</div><a href="https://www.hockeyjournal.com/podcast/" class="sm-ad-url" data-ad-id="76817" data-ad-name="Rink Shrinks" target="_blank"><img width="728" height="90" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20728%2090'%3E%3C/svg%3E" class="attachment-full size-full" alt="" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90.jpg 728w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90-300x37.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90-600x74.jpg 600w" data-lazy-sizes="(max-width: 728px) 100vw, 728px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90.jpg" /><noscript><img width="728" height="90" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90.jpg" class="attachment-full size-full" alt="" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90.jpg 728w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90-300x37.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/ads/TRS_728x90-600x74.jpg 600w" sizes="(max-width: 728px) 100vw, 728px" /></noscript></a></div><div class="single-wrap"></p><div><!--close wrap--><!-- AI CONTENT END 1 -->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-tags">Tags: <a href="https://www.hockeyjournal.com/tag/alex-gagne/" rel="tag">Alex Gagne</a>, <a href="https://www.hockeyjournal.com/tag/ben-meehan/" rel="tag">Ben Meehan</a>, <a href="https://www.hockeyjournal.com/tag/cedar-rapids-roughriders/" rel="tag">Cedar Rapids RoughRiders</a>, <a href="https://www.hockeyjournal.com/tag/d-j-hart/" rel="tag">D.J. Hart</a>, <a href="https://www.hockeyjournal.com/tag/derek-mullahy/" rel="tag">Derek Mullahy</a>, <a href="https://www.hockeyjournal.com/tag/dispersal-draft/" rel="tag">dispersal draft</a>, <a href="https://www.hockeyjournal.com/tag/doug-grimes/" rel="tag">Doug Grimes</a>, <a href="https://www.hockeyjournal.com/tag/garrett-sundquist/" rel="tag">Garrett Sundquist</a>, <a href="https://www.hockeyjournal.com/tag/madison-capitols/" rel="tag">Madison Capitols</a>, <a href="https://www.hockeyjournal.com/tag/ryan-mcguire/" rel="tag">Ryan McGuire</a>, <a href="https://www.hockeyjournal.com/tag/stephen-davis/" rel="tag">Stephen Davis</a>, <a href="https://www.hockeyjournal.com/tag/united-states-hockey-league/" rel="tag">United States Hockey League</a>, <a href="https://www.hockeyjournal.com/tag/ushl/" rel="tag">USHL</a></span></p></footer></article><div id="gated-content-cta"><div class="wrap"><section id="text-5" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Subscribe to finish reading this story</h4>
			<div class="textwidget"><p><a class="button" href="https://www.hockeyjournal.com/subscribe">SUBSCRIBE</a></p>
</div>
		</div></section>
<section id="gform_login_widget-2" class="widget gform_login_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Members login below</h4>
<div class='gf_browser_unknown gform_wrapper gf_login_form' id='gform_wrapper_0'><form method='post' id='gform_0'><input type='hidden' name='login_redirect' value='https://www.hockeyjournal.com/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/' /><div class='gform_body'><ul id='gform_fields_login' class='gform_fields top_label'><li id='field_1'  class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_1' >Username</label><div class='ginput_container ginput_container_text'><input name='input_1' id='input_1' type='text' value='' class=''   tabindex='1'  aria-required="true" aria-invalid="false" /></div></li><li id='field_2'  class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2' >Password</label><div class='ginput_container ginput_container_text'><input name='input_2' id='input_2' type='password' value='' class=''   tabindex='2'  aria-required="true" aria-invalid="false" /></div></li><li id='field_3'  class='gfield field_sublabel_below field_description_below hidden_label gfield_visibility_visible' ><label class='gfield_label'  ></label><div class='ginput_container ginput_container_checkbox'><ul class='gfield_checkbox' id='input_3'><li class='gchoice_3_1'>
								<input name='input_3.1' type='checkbox'  value='1'  id='choice_3_1' tabindex='3'  />
								<label for='choice_3_1' id='label_3_1'>Remember Me</label>
							</li></ul></div></li></ul>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_0' class='gform_button button' value='Login' tabindex='4' onclick='if(window["gf_submitting_0"]){return false;}  window["gf_submitting_0"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_0"]){return false;} window["gf_submitting_0"]=true;  jQuery("#gform_0").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_0' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='0' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='5f6a7d2a3aa91' />
            <input type='hidden' class='gform_hidden' name='state_0' value='WyJbXSIsIjlmYWRiZjA5NjczMjgzNWE1NDQ3NzA2NjAxYjYyNjIwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_0' id='gform_target_page_number_0' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_0' id='gform_source_page_number_0' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div></div></form></div><nav class="gf_login_links"><a href="https://www.hockeyjournal.com/wp-login.php?action=register" title="Register">Register</a><br /><a href="https://www.hockeyjournal.com/account/lost-password/" title="Forgot Password?">Forgot Password?</a><br /></nav></div></section>
</div></div><div class="related-articles"><h2>Related Articles</h2><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/harvards-henry-thrun-takes-detour-to-ushl-thayer-product-evan-googins-makes-commitment/"><img width="300" height="184" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20184'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC.jpg 775w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-300x184.jpg" /><noscript><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-300x184.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/09/Thrun-WEB-775-9.3.20-DC.jpg 775w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/harvards-henry-thrun-takes-detour-to-ushl-thayer-product-evan-googins-makes-commitment/">Harvard’s Henry Thrun takes detour to USHL, Thayer product Evan Googins makes commitment</a></h3><div class="archive-article-excerpt">Harvard defenseman Henry Thrun will start the season with the USHL’s Dubuque Fighting Saints. The ’01 from Southboro, Mass., is doing so because of uncertainty&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/harvards-henry-thrun-takes-detour-to-ushl-thayer-product-evan-googins-makes-commitment/">Read More</a></div><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/ushl-other-junior-leagues-ramping-up-plans-for-return-to-play/"><img width="300" height="184" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20184'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC.jpg 775w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-300x184.jpg" /><noscript><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-300x184.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/08/Colangelo-8.31.20-WEB-775-DC.jpg 775w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/ushl-other-junior-leagues-ramping-up-plans-for-return-to-play/">USHL, other junior leagues ramping up plans for return to play</a></h3><div class="archive-article-excerpt">While the National Hockey League continues its pursuit of crowning a champion for the 2019-20 campaign by conducting this year’s Stanley Cup playoffs in two&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/ushl-other-junior-leagues-ramping-up-plans-for-return-to-play/">Read More</a></div><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/nahl-entry-draft-cy-leclerc-max-bogdanovich-lead-new-england-crop/"><img width="300" height="184" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20184'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20.jpg 775w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-300x184.jpg" /><noscript><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-300x184.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2020/07/Ryan-MacDermott-top-02s-5.14.20-WEB-DC-775-7.23.20.jpg 775w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/nahl-entry-draft-cy-leclerc-max-bogdanovich-lead-new-england-crop/">NAHL Entry Draft: Cy Leclerc, Max Bogdanovich lead New England crop</a></h3><div class="archive-article-excerpt">Twenty-four players from New England were selected in the 2020 North American Hockey League Entry Draft that took place Tuesday. There were 33 other players&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/nahl-entry-draft-cy-leclerc-max-bogdanovich-lead-new-england-crop/">Read More</a></div></div></main></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="media_image-2" class="widget widget_media_image"><div class="widget-wrap"><img width="1954" height="631" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201954%20631'%3E%3C/svg%3E" class="image wp-image-197  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" data-lazy-srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png 1954w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-300x97.png 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-768x248.png 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-1024x331.png 1024w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-600x194.png 600w" data-lazy-sizes="(max-width: 1954px) 100vw, 1954px" data-lazy-src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png" /><noscript><img width="1954" height="631" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png" class="image wp-image-197  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png 1954w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-300x97.png 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-768x248.png 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-1024x331.png 1024w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-600x194.png 600w" sizes="(max-width: 1954px) 100vw, 1954px" /></noscript></div></section>
<section id="nav_menu-4" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-social-icons-menu-container"><ul id="menu-social-icons-menu" class="menu"><li id="menu-item-26" class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-26"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/NEHockeyJournal"><i class="fa fa-twitter-square" aria-hidden="true"></i></a></li>
<li id="menu-item-25" class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-25"><a target="_blank" rel="noopener noreferrer" href="https://Facebook.com/HockeyJournal"><i class="fa fa-facebook-square" aria-hidden="true"></i></a></li>
<li id="menu-item-71006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71006"><a href="https://www.instagram.com/newenglandhockeyjournal/"><i class="fa fa-instagram" aria-hidden="true"</i></i></a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Our Free Weekly Newsletter</h4>
			<div class="textwidget"><p><button class="popmake-377">Sign Up</button></p>
</div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-terms-menu-container"><ul id="menu-footer-terms-menu" class="menu"><li id="menu-item-535" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-535"><a href="https://www.hockeyjournal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21"><a href="https://www.seamansmedia.com/">Seamans Media, Inc.</a></li>
<li id="menu-item-1189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1189"><a href="https://www.hockeyjournal.com/privacy-policy-notice/">Privacy</a></li>
<li id="menu-item-1059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1059"><a href="https://www.hockeyjournal.com/contact/">Contact Us</a></li>
</ul></div></div></section>
<section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-social-icons-menu-container"><ul id="menu-social-icons-menu-1" class="menu"><li class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-26"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/NEHockeyJournal"><i class="fa fa-twitter-square" aria-hidden="true"></i></a></li>
<li class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-25"><a target="_blank" rel="noopener noreferrer" href="https://Facebook.com/HockeyJournal"><i class="fa fa-facebook-square" aria-hidden="true"></i></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71006"><a href="https://www.instagram.com/newenglandhockeyjournal/"><i class="fa fa-instagram" aria-hidden="true"</i></i></a></li>
</ul></div></div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>© Copyright 2020 Seamans Media, Inc. • All Rights Reserved </p></div></footer></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:15px;right:65px;background-color:transparent;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft%2F&amp;linkname=Ben%20Meehan%2C%20Derek%20Mullahy%20taken%20in%20USHL%20dispersal%20draft" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft%2F&amp;linkname=Ben%20Meehan%2C%20Derek%20Mullahy%20taken%20in%20USHL%20dispersal%20draft" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft%2F&amp;linkname=Ben%20Meehan%2C%20Derek%20Mullahy%20taken%20in%20USHL%20dispersal%20draft" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div><div id="pum-377" class="pum pum-overlay pum-theme-376 pum-theme-default-theme popmake-overlay click_open" data-popmake="{&quot;id&quot;:377,&quot;slug&quot;:&quot;newsletter&quot;,&quot;theme_id&quot;:376,&quot;cookies&quot;:[],&quot;triggers&quot;:[{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;medium&quot;,&quot;responsive_min_width&quot;:&quot;0%&quot;,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:&quot;100%&quot;,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:&quot;640px&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;380px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:&quot;center top&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_377">

	<div id="popmake-377" class="pum-container popmake theme-376 pum-responsive pum-responsive-medium responsive size-medium">

				

				            <div id="pum_popup_title_377" class="pum-title popmake-title">
				Free Newsletter Subscription			</div>
		

		

				<div class="pum-content popmake-content">
			<p>Receive our <em>NEHJ Insider</em> newsletter to your inbox.</p>

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_1' ><form method='post' enctype='multipart/form-data'  id='gform_1'  action='/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/'> 
 <input type='hidden' class='gforms-pum' value='{"closepopup":false,"closedelay":0,"openpopup":false,"openpopup_id":0}' />
                        <div class='gform_body'><ul id='gform_fields_1' class='gform_fields top_label form_sublabel_below description_below'><li id='field_1_1'  class='gfield gf-nofield-label gfield_contains_required field_sublabel_above field_description_below gfield_visibility_visible' ><label class='gfield_label gfield_label_before_complex'  >Name<span class='gfield_required'>*</span></label><div class='ginput_complex ginput_container no_prefix has_first_name no_middle_name has_last_name no_suffix gf_name_has_2 ginput_container_name' id='input_1_1'>
                            
                            <span id='input_1_1_3_container' class='name_first' >
                                                    <label for='input_1_1_3' >First</label>
                                                    <input type='text' name='input_1.3' id='input_1_1_3' value='' aria-label='First name'   aria-required="true" aria-invalid="false" placeholder='First Name'/>
                                                </span>
                            
                            <span id='input_1_1_6_container' class='name_last' >
                                                            <label for='input_1_1_6' >Last</label>
                                                            <input type='text' name='input_1.6' id='input_1_1_6' value='' aria-label='Last name'   aria-required="true" aria-invalid="false" placeholder='Last Name'/>
                                                        </span>
                            
                        </div></li><li id='field_1_2'  class='gfield gf-nofield-label gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_1_2' >Email<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_2' id='input_1_2' type='text' value='' class='large'   placeholder='Email' aria-required="true" aria-invalid="false" />
                        </div></li><li id='field_1_3'  class='gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_1_3' >Phone</label><div class='ginput_container'><input name='input_3' id='input_1_3' type='text' value='' /></div><div class='gfield_description' id='gfield_description__3'>This field is for validation purposes and should be left unchanged.</div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_1' class='gform_button button' value='sign up'  onclick='if(window["gf_submitting_1"]){return false;}  window["gf_submitting_1"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_1"]){return false;} window["gf_submitting_1"]=true;  jQuery("#gform_1").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_1' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='1' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_1' value='WyJbXSIsIjlmYWRiZjA5NjczMjgzNWE1NDQ3NzA2NjAxYjYyNjIwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_1' id='gform_target_page_number_1' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_1' id='gform_source_page_number_1' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			CLOSE            </button>
		
	</div>

</div>
<div id="pum-378" class="pum pum-overlay pum-theme-376 pum-theme-default-theme popmake-overlay click_open" data-popmake="{&quot;id&quot;:378,&quot;slug&quot;:&quot;contact&quot;,&quot;theme_id&quot;:376,&quot;cookies&quot;:[],&quot;triggers&quot;:[{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:false,&quot;responsive_min_width&quot;:false,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:false,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:false,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:false,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:false,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:false,&quot;position_left&quot;:false,&quot;position_bottom&quot;:false,&quot;position_right&quot;:false,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:false,&quot;animation_speed&quot;:false,&quot;animation_origin&quot;:false,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:false},&quot;close&quot;:{&quot;text&quot;:false,&quot;button_delay&quot;:false,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_378">

	<div id="popmake-378" class="pum-container popmake theme-376 pum-responsive pum-responsive-medium responsive size-medium">

				

				            <div id="pum_popup_title_378" class="pum-title popmake-title">
				Contact Us!			</div>
		

		

				<div class="pum-content popmake-content">
			<p>Please write a brief description and someone will get back to you shortly!<br />

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_2' ><form method='post' enctype='multipart/form-data'  id='gform_2'  action='/ben-meehan-derek-mullahy-among-new-englanders-taken-in-ushl-dispersal-draft/'> 
 <input type='hidden' class='gforms-pum' value='{"closepopup":false,"closedelay":0,"openpopup":false,"openpopup_id":0}' />
                        <div class='gform_body'><ul id='gform_fields_2' class='gform_fields top_label form_sublabel_below description_below'><li id='field_2_1'  class='gfield gf-nofield-label gfield_contains_required field_sublabel_above field_description_above gfield_visibility_visible' ><label class='gfield_label gfield_label_before_complex'  >Name<span class='gfield_required'>*</span></label><div class='ginput_complex ginput_container no_prefix has_first_name no_middle_name has_last_name no_suffix gf_name_has_2 ginput_container_name' id='input_2_1'>
                            
                            <span id='input_2_1_3_container' class='name_first' >
                                                    <label for='input_2_1_3' >First</label>
                                                    <input type='text' name='input_1.3' id='input_2_1_3' value='' aria-label='First name'   aria-required="true" aria-invalid="false" placeholder='First Name'/>
                                                </span>
                            
                            <span id='input_2_1_6_container' class='name_last' >
                                                            <label for='input_2_1_6' >Last</label>
                                                            <input type='text' name='input_1.6' id='input_2_1_6' value='' aria-label='Last name'   aria-required="true" aria-invalid="false" placeholder='Last Name'/>
                                                        </span>
                            
                        </div></li><li id='field_2_3'  class='gfield gf-nofield-label gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_3' >Email<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_3' id='input_2_3' type='text' value='' class='large'   placeholder='Email Address' aria-required="true" aria-invalid="false" />
                        </div></li><li id='field_2_4'  class='gfield field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_4' ></label><div id='input_2_4' class='ginput_container ginput_recaptcha' data-sitekey='6Le_ZsIZAAAAAFJXN5UBjhaauMogPPmGQ9eKYIwj'  data-theme='light' data-tabindex='-1' data-size='invisible' data-badge='bottomright'></div></li><li id='field_2_2'  class='gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_2' >Brief Description<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_textarea'><textarea name='input_2' id='input_2_2' class='textarea large'     aria-required="true" aria-invalid="false"   rows='10' cols='50'></textarea></div></li><li id='field_2_5'  class='gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_2_5' >Name</label><div class='ginput_container'><input name='input_5' id='input_2_5' type='text' value='' /></div><div class='gfield_description' id='gfield_description__5'>This field is for validation purposes and should be left unchanged.</div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_2' class='gform_button button' value='Submit'  onclick='if(window["gf_submitting_2"]){return false;}  window["gf_submitting_2"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_2"]){return false;} window["gf_submitting_2"]=true;  jQuery("#gform_2").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_2' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='2' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_2' value='WyJbXSIsIjlmYWRiZjA5NjczMjgzNWE1NDQ3NzA2NjAxYjYyNjIwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_2' id='gform_target_page_number_2' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_2' id='gform_source_page_number_2' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			&#215;            </button>
		
	</div>

</div>
	
	





<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.hockeyjournal.com\/checkout\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>


<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>




<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"version":"1.11.2","pm_dir_url":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/popup-maker\/","ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","restapi":"https:\/\/www.hockeyjournal.com\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"376","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[]};
var ajaxurl = "https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php";
var pum_sub_vars = {"ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-377":{"disable_on_mobile":false,"disable_on_tablet":false,"custom_height_auto":false,"scrollable_content":false,"position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"close_on_form_submission":false,"close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_id":"376","size":"medium","responsive_min_width":"0%","responsive_max_width":"100%","custom_width":"640px","custom_height":"380px","animation_type":"fade","animation_speed":"350","animation_origin":"center top","location":"center top","position_top":"100","position_bottom":"0","position_left":"0","position_right":"0","zindex":"1999999999","close_button_delay":"0","triggers":[],"cookies":[],"theme_slug":"default-theme","id":377,"slug":"newsletter"},"pum-378":{"disable_on_mobile":false,"disable_on_tablet":false,"custom_height_auto":false,"scrollable_content":false,"position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"close_on_form_submission":false,"close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"default-theme","theme_id":376,"id":378,"slug":"contact"}};
/* ]]> */
</script>

<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?hl=en&#038;render=explicit&#038;ver=5.4.2'></script>
		

		<!-- WooCommerce JavaScript -->

<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.hockeyjournal.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script src="https://www.hockeyjournal.com/wp-content/cache/min/2/9cdcdb1f7a181973b33660475135d601.js" data-minify="1" defer></script><script type='text/javascript'> jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 1) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [1, 1]) } ); </script><script type='text/javascript'> jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 2) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [2, 1]) } ); </script><script type="text/javascript">
			( function( $ ) {
				$( document ).bind( 'gform_post_render', function() {
					var gfRecaptchaPoller = setInterval( function() {
						if( ! window.grecaptcha || ! window.grecaptcha.render ) {
							return;
						}
						renderRecaptcha();
						clearInterval( gfRecaptchaPoller );
					}, 100 );
				} );
			} )( jQuery );
		</script></body></html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->