<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<script type="text/javascript">
if(!gform){document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0});var gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),null==t&&(t=10),gform.hooks[o][n].push({tag:i,callable:r,priority:t})},doHook:function(o,n,r){if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[o][n]){var t,i=gform.hooks[o][n];i.sort(function(o,n){return o.priority-n.priority});for(var e=0;e<i.length;e++)"function"!=typeof(t=i[e].callable)&&(t=window[t]),"action"==o?t.apply(null,r):r[0]=t.apply(null,r)}if("filter"==o)return r[0]},removeHook:function(o,n,r,t){if(null!=gform.hooks[o][n])for(var i=gform.hooks[o][n],e=i.length-1;0<=e;e--)null!=t&&t!=i[e].tag||null!=r&&r!=i[e].priority||i.splice(e,1)}}}
</script>

<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
	<!-- This site is optimized with the Yoast SEO plugin v17.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Analysis: Early awards and key performances of 2006 forwards</title>
	<meta name="description" content="With the Columbus Day holiday and big area tournaments about to start, we look at some of the early standouts from the 2006 birth year." />
	<link rel="canonical" href="https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Analysis: Early awards and key performances of 2006 forwards" />
	<meta property="og:description" content="With the Columbus Day holiday and big area tournaments about to start, we look at some of the early standouts from the 2006 birth year." />
	<meta property="og:url" content="https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/" />
	<meta property="og:site_name" content="New England Hockey Journal" />
	<meta property="article:published_time" content="2021-10-07T21:21:31+00:00" />
	<meta property="article:modified_time" content="2021-10-07T22:27:24+00:00" />
	<meta property="og:image" content="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg" />
	<meta property="og:image:width" content="775" />
	<meta property="og:image:height" content="475" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Kirk Luedeke" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.hockeyjournal.com/#organization","name":"Seamans Media Inc","url":"https://www.hockeyjournal.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/#logo","inLanguage":"en-US","url":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/logo.png","contentUrl":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/logo.png","width":202,"height":74,"caption":"Seamans Media Inc"},"image":{"@id":"https://www.hockeyjournal.com/#logo"}},{"@type":"WebSite","@id":"https://www.hockeyjournal.com/#website","url":"https://www.hockeyjournal.com/","name":"New England Hockey Journal","description":"","publisher":{"@id":"https://www.hockeyjournal.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.hockeyjournal.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#primaryimage","inLanguage":"en-US","url":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg","contentUrl":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg","width":775,"height":475,"caption":"Teddy Stiga (Sudbury, Mass.) is a left-shot forward for Belmont Hill and the Boston Junior Eagles. (Al Aleman/USA Hockey)"},{"@type":"WebPage","@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#webpage","url":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/","name":"Analysis: Early awards and key performances of 2006 forwards","isPartOf":{"@id":"https://www.hockeyjournal.com/#website"},"primaryImageOfPage":{"@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#primaryimage"},"datePublished":"2021-10-07T21:21:31+00:00","dateModified":"2021-10-07T22:27:24+00:00","description":"With the Columbus Day holiday and big area tournaments about to start, we look at some of the early standouts from the 2006 birth year.","breadcrumb":{"@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/"]}]},{"@type":"BreadcrumbList","@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.hockeyjournal.com/"},{"@type":"ListItem","position":2,"name":"Analysis: Early awards and key performances of 2006 forwards"}]},{"@type":"Article","@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#article","isPartOf":{"@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#webpage"},"author":{"@id":"https://www.hockeyjournal.com/#/schema/person/745dab90ea314d1d2ba1924b80e49fc8"},"headline":"Analysis: Early awards and key performances of 2006 forwards","datePublished":"2021-10-07T21:21:31+00:00","dateModified":"2021-10-07T22:27:24+00:00","mainEntityOfPage":{"@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#webpage"},"wordCount":1664,"publisher":{"@id":"https://www.hockeyjournal.com/#organization"},"image":{"@id":"https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/#primaryimage"},"thumbnailUrl":"https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg","keywords":["2006 birth year","Bishop Kearney Selects","Boston Junior Eagles","Boston Little Bruins","Cape Cod Whalers","Long Island Gulls","Mid Fairfield","Mount Saint Charles","Neponset Valley River Rats","New Jersey Rockets","South Kent Selects"],"articleSection":["Featured","Prospects"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.hockeyjournal.com/#/schema/person/745dab90ea314d1d2ba1924b80e49fc8","name":"Kirk Luedeke","image":{"@type":"ImageObject","@id":"https://www.hockeyjournal.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e00b23177b41e3a63b30b835d6bae1e7?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e00b23177b41e3a63b30b835d6bae1e7?s=96&d=mm&r=g","caption":"Kirk Luedeke"},"url":"https://www.hockeyjournal.com/author/kirkluedeke/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="New England Hockey Journal &raquo; Feed" href="https://www.hockeyjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="New England Hockey Journal &raquo; Comments Feed" href="https://www.hockeyjournal.com/comments/feed/" />
<link rel="preload" href="https://www.hockeyjournal.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.3/webfonts/fa-brands-400.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.hockeyjournal.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.3/webfonts/fa-solid-900.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.hockeyjournal.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.3/webfonts/fa-regular-400.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='seamans-media-sports-theme-css'  href='https://www.hockeyjournal.com/wp-content/themes/seamans-sports/style.css?ver=1.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.hockeyjournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='supersideme-style-css'  href='https://www.hockeyjournal.com/wp-content/plugins/superside-me/includes/css/supersideme-style.css?ver=2.7.3' type='text/css' media='screen' />
<style id='supersideme-style-inline-css' type='text/css'>
nav,#nav,.nav-primary,.nav-secondary,.supersideme .site-header .secondary-toggle,.menu-toggle {display:none }.slide-nav-link,.ssme-search,.button.ssme-button.ssme-custom {display:block }.sidr {width:330px }.sidr.left {left:-330px }.sidr.right {right:-330px }.slide-nav-link {background-color:#fff;left:0;color:#050505;position:relative;width:auto }.sidr {background-color:#fff;color:#050505 }.sidr h3,.sidr h4,.sidr .widget,.sidr p {color:#050505 }.slide-nav-link:focus,.sidr:focus,.sidr a:focus,.menu-close:focus,.sub-menu-toggle:focus {outline:#050505 dotted 1px }.sidr a,.sidr a:focus,.sidr a:active,.sidr button,.sidr .sub-menu-toggle:before {color:#050505 }.search-me {color:#fff }.slide-nav-link:before,.search-me:before,.menu-close:before,.sidr .sub-menu-toggle:before,.ssme-search:before,.ssme-button:before {-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;display:inline-block;font-style:normal;font-variant:normal;font-weight:900;font-family:'Font Awesome 5 Free','FontAwesome';font-size:20px }.menu-close:before,.sidr .sub-menu-toggle:before {font-size:16px }.slide-nav-link:before {content:'\f0c9' }.slide-nav-link.menu-open:before {content:'\f0c9' }.sidr .menu-close:before {content:'\f00d' }.sidr .sub-menu-toggle:before {content:'\f107' }.sidr .sub-menu-toggle-open:before {content:'\f106' }.search-me:before {content:'\f002' }.ssme-search:before {content:'\f002' }
</style>
<link rel='stylesheet' id='font-awesome-5-css'  href='https://www.hockeyjournal.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.3/css/all.min.css?ver=2.5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.hockeyjournal.com/wp-content/plugins/bb-plugin/fonts/fontawesome/5.15.3/css/v4-shims.min.css?ver=2.5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='follow-up-emails-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce-follow-up-emails/templates/followups.css?ver=4.9.15' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.7.1' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=5.7.1' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='ad-manager-css-css'  href='https://www.hockeyjournal.com/wp-content/plugins/sm-ad-manager-21/ad-manager.css?ver=0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-memberships-frontend-css'  href='https://www.hockeyjournal.com/wp-content/plugins/woocommerce-memberships/assets/css/frontend/wc-memberships-frontend.min.css?ver=1.22.5' type='text/css' media='all' />
<link rel='stylesheet' id='sm-stylesheet-css'  href='https://www.hockeyjournal.com/wp-content/themes/seamans-sports/style.css?ver=1618262991' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.hockeyjournal.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_reset_css-css'  href='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/legacy/css/formreset.min.css?ver=2.5.12' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/legacy/css/formsmain.min.css?ver=2.5.12' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/legacy/css/readyclass.min.css?ver=2.5.12' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/legacy/css/browsers.min.css?ver=2.5.12' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='//www.hockeyjournal.com/wp-content/uploads/sites/2/pum/pum-site-styles-2.css?generated=1625775951&#038;ver=1.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.hockeyjournal.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://www.hockeyjournal.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' id='fue-account-subscriptions-js-extra'>
/* <![CDATA[ */
var FUE = {"ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","ajax_loader":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/woocommerce-follow-up-emails\/templates\/images\/ajax-loader.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce-follow-up-emails/templates/js/fue-account-subscriptions.js?ver=4.9.15' id='fue-account-subscriptions-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.13.1' id='gtm4wp-form-move-tracker-js'></script>
<script type='text/javascript' defer='defer' src='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.5.12' id='gform_json-js'></script>
<script type='text/javascript' id='gform_gravityforms-js-extra'>
/* <![CDATA[ */
var gform_i18n = {"datepicker":{"days":{"monday":"Mon","tuesday":"Tue","wednesday":"Wed","thursday":"Thu","friday":"Fri","saturday":"Sat","sunday":"Sun"},"months":{"january":"January","february":"February","march":"March","april":"April","may":"May","june":"June","july":"July","august":"August","september":"September","october":"October","november":"November","december":"December"},"firstDay":1,"iconText":"Select date"}};
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
var gf_legacy_multi = {"2":"1"};
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
var gf_legacy_multi = {"2":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.5.12' id='gform_gravityforms-js'></script>
<script type='text/javascript' defer='defer' src='https://www.google.com/recaptcha/api.js?hl=en&#038;ver=5.8.1#038;render=explicit' id='gform_recaptcha-js'></script>
<script type='text/javascript' id='enr-frontend-js-extra'>
/* <![CDATA[ */
var enr_frontend_params = {"ajax_url":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","subscribe_now_nonce":"19cb6b1929","subscribe_now_button_text":"Subscribe","single_add_to_cart_text":"Add to cart","hide_variable_limited_notice":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/enhancer-for-woocommerce-subscriptions/assets/js/frontend.js?ver=2.8' id='enr-frontend-js'></script>
<link rel="https://api.w.org/" href="https://www.hockeyjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.hockeyjournal.com/wp-json/wp/v2/posts/90236" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.hockeyjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.hockeyjournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.hockeyjournal.com/?p=90236' />
<link rel="alternate" type="application/json+oembed" href="https://www.hockeyjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hockeyjournal.com%2Fanalysis-early-awards-and-key-performances-of-2006-forwards%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.hockeyjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hockeyjournal.com%2Fanalysis-early-awards-and-key-performances-of-2006-forwards%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<!-- Stream WordPress user activity plugin v3.8.1 -->

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["featured","prospects"],"pageAttributes":["2006-birth-year","bishop-kearney-selects","boston-junior-eagles","boston-little-bruins","cape-cod-whalers","long-island-gulls","mid-fairfield","mount-saint-charles","neponset-valley-river-rats","new-jersey-rockets","south-kent-selects"],"pagePostAuthor":"Kirk Luedeke"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TWLJ2SQ');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->         <style type="text/css">
             .site-header { background-color: #24305c; } 
			 .header-image .site-title a { background-image: url(https://cdn.seamansmedianetwork.com/wp-content/uploads/sites/2/2018/04/27190517/NEHockey-Journal_white-1.png)}
         </style>
             <style type="text/css" id="customizer-colors">
			 
			 /*Background color*/
			.site-header, .button, .site-header #slide-menu, .footer-widgets, .site-footer, .woocommerce #respond input#submit.alt, .woocommerce a.button.alt, .woocommerce button.button.alt, .woocommerce input.button.alt, .woocommerce #respond input#submit, .woocommerce a.button, .woocommerce button.button, .woocommerce input.button, .menu-close {  background-color: #24305c  !important; }
			 
			 /* Subscribe Heading */
			 .subscribe-heading { color: #24305c  !important; border-color: #24305c  !important; }
			 
			 /*A tag color*/
			.entry-tags a, .entry-content p a, .woocommerce-info::before, #home-top-right .sm-headlines li::marker { color: #dd3333 !important; }
			 
			/*hover color*/
			.featured-content .entry-title a:hover, .related-video h4 a:hover, .video-archive-link:hover,.entry-title a:hover, .entry-title a:focus, a.more-link:hover, .category-featured-content a:hover, .single-post-display-category:hover, .entry-tags a:hover, .archive-article-item .archive-article-title a:hover, .related-read-more:hover,  .entry-content p a:hover { color: #5888e8 !important; }
			 
			 
			/*text in buttons and background color*/
			.right-header-menu .menu .menu-item a .button, #slide-menu:before, .woocommerce #respond input#submit, .woocommerce a.button, .woocommerce button.button, .woocommerce input.button, .category-archive-title, .category-featured-content, .category-featured-content a, a.pdf-download, a.subscribe-button { color: #ffffff !important;}
			 
			/* Button Text Hover Color */
			button:hover, input:hover[type="button"], input:hover[type="reset"], input:hover[type="submit"], .button:hover, button:focus, input:focus[type="button"], input:focus[type="reset"], input:focus[type="submit"], .button:focus, .woocommerce a.button.alt:hover, .woocommerce button.button.alt:hover, .woocommerce input.button.alt:hover,.woocommerce a.button:hover, .woocommerce button.button:hover, .woocommerce input.button:hover { color: #ffffff !important;}
			 
			/*WooCommerce Price Color*/
			.woocommerce div.product p.price, .woocommerce div.product span.price, .woocommerce ul.products li.product .price {color: #24305c !important;}
			 
			/*Primary Border Color*/
			.single-post .entry-header, .related-articles h2, .home .site-inner .widgettitle a, #home-four section.featuredpost:last-of-type article:after,.single-video .season-title, .archive .season-title, .directory-listings .directory-entry .profile-image, .category-permalink, .woocommerce-info, #home-top .widgettitle span, .home .widget_sm_headlines_widget .widgettitle,#home-top-right .widget_sm_headlines_widget, #home-top-right .widget_media_image .widget-title, #home-top-right-carousel .widget-title  { border-color: #24305c !important;}
			 
			/*Secondary Border Color*/
			.video-archive-link, .woocommerce-message { border-color: #24305c !important; }
			 
			/*Secondary Link Color*/
			.video-archive-link, .woocommerce-message::before { color: #24305c !important;  }
			 
			/*Secondary Background Color*/
			#gated-content-cta .widget .gform_wrapper .gform_footer input, .woocommerce #login-widget-area a.button.subscribe-button {background-color: #24305c !important;}
			 
			 
         </style>
    <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '3296317370385606'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=3296317370385606&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->

<meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css"><link href="https://fonts.googleapis.com/css?family=Open+Sans:400,600|Roboto:400,500,700" rel="stylesheet"><script src="https://seamansmedia.activehosted.com/f/embed.php?id=9" type="text/javascript" charset="utf-8"></script>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192-100x100.png" sizes="32x32" />
<link rel="icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" />
<meta name="msapplication-TileImage" content="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/05/android-icon-192x192.png" />
		<style type="text/css" id="wp-custom-css">
			.archive .category-hero { background-color: #808080 !important}
		</style>
		<!-- WooCommerce Google Analytics Integration -->
		<script type='text/javascript'>
			var gaProperty = 'UA-119829409-2';
			var disableStr = 'ga-disable-' + gaProperty;
			if ( document.cookie.indexOf( disableStr + '=true' ) > -1 ) {
				window[disableStr] = true;
			}
			function gaOptout() {
				document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
				window[disableStr] = true;
			}
		</script><script type='text/javascript'>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script', '//www.google-analytics.com/analytics.js','ga');ga( 'create', 'UA-119829409-2', 'auto' );(window.gaDevIds=window.gaDevIds||[]).push('dOGY3NW');ga( 'require', 'linkid' );ga( 'set', 'anonymizeIp', true );
		ga( 'set', 'dimension1', 'no' );
ga( 'require', 'ecommerce', 'ecommerce.js');</script>
		<!-- /WooCommerce Google Analytics Integration --><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-90236 single-format-standard theme-genesis no-js woocommerce-no-js membership-content access-restricted has-featured-image header-image header-full-width full-width-content genesis-breadcrumbs-hidden genesis-footer-widgets-visible">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TWLJ2SQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><script>/* <![CDATA[ */(function(){var c = document.body.classList;c.remove('no-js');c.add('js');})();/* ]]> */</script>
		
<!-- Google Tag Manager (noscript) --><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://www.hockeyjournal.com/">New England Hockey Journal</a></p></div><div class="right-header-menu"><div class="menu-right-menu-container"><ul id="menu-right-menu" class="menu"><li id="menu-item-12" class="log-show menu-item menu-item-type-post_type menu-item-object-page menu-item-12"><a href="https://www.hockeyjournal.com/account/">Login</a></li>
<li id="menu-item-420" class="log-hide menu-item menu-item-type-custom menu-item-object-custom menu-item-420"><a href="https://www.hockeyjournal.com/account/customer-logout/?_wpnonce=f01283bcac">Logout</a></li>
<li id="menu-item-517" class="log-show menu-item menu-item-type-post_type menu-item-object-page menu-item-517"><a href="https://www.hockeyjournal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-96" class="log-hide menu-item menu-item-type-custom menu-item-object-custom menu-item-96"><a href="http://www.hockeyjournal.com/account/">Dashboard</a></li>
</ul></div></div></div></header><div class="site-inner"><div class="sm-ad-box header-ad-slot"><!-- BEGIN ADVERTSERVE CODE -->
<div id="dRXRcfNWDGxEGQUHnHHd">
<script type="text/javascript">
var _avp = _avp || [];
_avp.push({ tagid: 'dRXRcfNWDGxEGQUHnHHd', alias: '/', type: 'banner', zid: 6, pid: 0, secure: true });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div><div class="content-sidebar-wrap"><main class="content"><article class="post-90236 post type-post status-publish format-standard has-post-thumbnail category-featured category-prospects tag-2006-birth-year tag-bishop-kearney-selects tag-boston-junior-eagles tag-boston-little-bruins tag-cape-cod-whalers tag-long-island-gulls tag-mid-fairfield tag-mount-saint-charles tag-neponset-valley-river-rats tag-new-jersey-rockets tag-south-kent-selects access_level-premium-subscriber membership-content access-restricted entry gs-1 gs-odd gs-even gs-featured-content-entry" aria-label="Analysis: Early awards and key performances of 2006 forwards"><header class="entry-header"><div class="subscribe-heading"><a href="/subscribe/">Subscribe</a></div><a class="single-post-display-category" href="https://www.hockeyjournal.com/category/prospects/">Prospects</a><h1 class="entry-title">Analysis: Early awards and key performances of 2006 forwards</h1>
<div class="subheading"></div><p class="entry-meta"><div class="author-block"><span class="author-avatar"><img alt='' src='https://secure.gravatar.com/avatar/e00b23177b41e3a63b30b835d6bae1e7?s=64&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e00b23177b41e3a63b30b835d6bae1e7?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' /></span><div class="author-meta-block">By <a href="https://www.hockeyjournal.com/author/kirkluedeke/" itemprop="url" rel="author">Kirk Luedeke</a><time class="entry-time">October 7, 2021</time></div></div></p></header><div class="entry-content"><div class="article-featured-image"><img width="775" height="475" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg" class="attachment-large size-large wp-post-image" alt="Teddy Stiga" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2.jpg 775w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/10/Teddy-Stiga-Web-775-LF-2-600x368.jpg 600w" sizes="(max-width: 775px) 100vw, 775px" /><div class="single-image-caption">Teddy Stiga (Sudbury, Mass.) is a left-shot forward for Belmont Hill and the Boston Junior Eagles. (Al Aleman/USA Hockey)</div></div><p style="font-weight: 400;">With the Columbus Day holiday and big area tournaments about to start, it is time to look at some of the early standout performers from the 2006 birth year.</p>
<p style="font-weight: 400;">As we are still working our way through the teams and rinks, the players listed here are the ones we have had live viewings of. As the 2021-22 fall hockey season progresses, we will see more teams and periodically provide updates on the various birth years.</p>
<p style="font-weight: 400;">As always, we call it like we see it. Strong performances in viewed games may or may not be indicative of a bigger, season-long trend, but is a reflection of firsthand observations that are more than one, but still relatively limited in number given the timeline.</p>
<p style="font-weight: 400;">This piece analyzes the early action and is meant to raise the profile of these individuals. It is not the definitive accounting or final word on their season or an indictment of players who do not appear here.</p>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-tags">Tags: <a href="https://www.hockeyjournal.com/tag/2006-birth-year/" rel="tag">2006 birth year</a>, <a href="https://www.hockeyjournal.com/tag/bishop-kearney-selects/" rel="tag">Bishop Kearney Selects</a>, <a href="https://www.hockeyjournal.com/tag/boston-junior-eagles/" rel="tag">Boston Junior Eagles</a>, <a href="https://www.hockeyjournal.com/tag/boston-little-bruins/" rel="tag">Boston Little Bruins</a>, <a href="https://www.hockeyjournal.com/tag/cape-cod-whalers/" rel="tag">Cape Cod Whalers</a>, <a href="https://www.hockeyjournal.com/tag/long-island-gulls/" rel="tag">Long Island Gulls</a>, <a href="https://www.hockeyjournal.com/tag/mid-fairfield/" rel="tag">Mid Fairfield</a>, <a href="https://www.hockeyjournal.com/tag/mount-saint-charles/" rel="tag">Mount Saint Charles</a>, <a href="https://www.hockeyjournal.com/tag/neponset-valley-river-rats/" rel="tag">Neponset Valley River Rats</a>, <a href="https://www.hockeyjournal.com/tag/new-jersey-rockets/" rel="tag">New Jersey Rockets</a>, <a href="https://www.hockeyjournal.com/tag/south-kent-selects/" rel="tag">South Kent Selects</a></span></p></footer></article><div id="gated-content-cta"><div class="wrap"><section id="text-5" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Subscribe to finish reading this story</h4>
			<div class="textwidget"><p><a class="button" href="https://www.hockeyjournal.com/subscribe">SUBSCRIBE</a></p>
</div>
		</div></section>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/dom-ready.min.js?ver=71883072590656bf22c74c7b887df3dd' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/hooks.min.js?ver=a7edae857aab69d69fa10d5aef23a5de' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/dist/a11y.min.js?ver=0ac8327cc1c40dcfdf29716affd7ac63' id='wp-a11y-js'></script>
<section id="gform_login_widget-2" class="widget gform_login_widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Members login below</h4>
<div class='gf_browser_unknown gform_wrapper gf_login_form' id='gform_wrapper_0'><form method='post' id='gform_0'><input type='hidden' name='login_redirect' value='https://www.hockeyjournal.com/analysis-early-awards-and-key-performances-of-2006-forwards/' /><div class='gform_body'><ul id='gform_fields_login' class='gform_fields top_label'><li id="field_1" class="gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label' for='input_1' >Username<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_text'><input name='input_1' id='input_1' type='text' value='' class=''   tabindex='1'  aria-required="true" aria-invalid="false"   /> </div></li><li id="field_2" class="gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label' for='input_2' >Password<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_text'><input name='input_2' id='input_2' type='password' value='' class=''   tabindex='2'  aria-required="true" aria-invalid="false"   /> </div></li><li id="field_3" class="gfield field_sublabel_below field_description_below hidden_label gfield_visibility_visible" ><label class='gfield_label screen-reader-text gfield_label_before_complex'  ></label><div class='ginput_container ginput_container_checkbox'><ul class='gfield_checkbox' id='input_3'><li class='gchoice gchoice_3_1'>
								<input class='gfield-choice-input' name='input_3.1' type='checkbox'  value='1'  id='choice_3_1' tabindex='3'  />
								<label for='choice_3_1' id='label_3_1'>Remember Me</label>
							</li></ul></div></li></ul>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_0' class='gform_button button' value='Login' tabindex='4' onclick='if(window["gf_submitting_0"]){return false;}  window["gf_submitting_0"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_0"]){return false;} window["gf_submitting_0"]=true;  jQuery("#gform_0").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_0' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='0' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='615f75726ef5b' />
            <input type='hidden' class='gform_hidden' name='state_0' value='WyJbXSIsIjlmYWRiZjA5NjczMjgzNWE1NDQ3NzA2NjAxYjYyNjIwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_0' id='gform_target_page_number_0' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_0' id='gform_source_page_number_0' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div></div></form></div><nav class="gf_login_links"><a href="https://www.hockeyjournal.com/wp-login.php?action=register" title="Register">Register</a><br /><a href="https://www.hockeyjournal.com/account/lost-password/" title="Forgot Password?">Forgot Password?</a><br /></nav></div></section>
</div></div><div class="related-articles"><h2>Related Articles</h2><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/river-rats-jamboree-why-these-15-u-players-impressed/"><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/2021-River-Rats-Jamboree-Web-775-LF-300x184.jpeg" class="attachment-medium size-medium wp-post-image" alt="2021 River Rats Jamboree" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/2021-River-Rats-Jamboree-Web-775-LF-300x184.jpeg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/2021-River-Rats-Jamboree-Web-775-LF-768x471.jpeg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/2021-River-Rats-Jamboree-Web-775-LF-600x368.jpeg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/2021-River-Rats-Jamboree-Web-775-LF.jpeg 775w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/river-rats-jamboree-why-these-15-u-players-impressed/">River Rats Jamboree: Why these 15-U players impressed</a></h3><div class="archive-article-excerpt">The recently concluded 2021 River Rats Jamboree featured rising young hockey talent competing in the 15-U division from the 2006 birth year at several Massachusetts&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/river-rats-jamboree-why-these-15-u-players-impressed/">Read More</a></div><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/northeast-pack-hockey-15-only-standouts-off-to-a-hot-start/"><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/Will-Felicio-Web-775-LF-300x184.jpg" class="attachment-medium size-medium wp-post-image" alt="Will Felicio" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/Will-Felicio-Web-775-LF-300x184.jpg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/Will-Felicio-Web-775-LF-768x471.jpg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/Will-Felicio-Web-775-LF-600x368.jpg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/Will-Felicio-Web-775-LF.jpg 775w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/northeast-pack-hockey-15-only-standouts-off-to-a-hot-start/">Northeast Pack Hockey: 15 Only standouts off to a hot start</a></h3><div class="archive-article-excerpt">WOONSOCKET, R.I. — The first Northeast Pack Hockey League event of the season took place in Rhode Island and New York over the weekend. Mount&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/northeast-pack-hockey-15-only-standouts-off-to-a-hot-start/">Read More</a></div><div class="archive-article-item"><div class="archive-article-image"><a href="https://www.hockeyjournal.com/analysis-strong-performers-in-mount-st-charles-vs-cape-cod-whalers-15o-game/"><img width="300" height="184" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/MSC-CCW-15O-Web-775-300x184.jpeg" class="attachment-medium size-medium wp-post-image" alt="Mount Saint Charles" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/MSC-CCW-15O-Web-775-300x184.jpeg 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/MSC-CCW-15O-Web-775-768x471.jpeg 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/MSC-CCW-15O-Web-775-600x368.jpeg 600w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2021/09/MSC-CCW-15O-Web-775.jpeg 775w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><h3 class="archive-article-title"><a href="https://www.hockeyjournal.com/analysis-strong-performers-in-mount-st-charles-vs-cape-cod-whalers-15o-game/">Analysis: Mount St. Charles vs. Cape Cod Whalers 15 Only standouts</a></h3><div class="archive-article-excerpt">FOXBORO, Mass. — In a rematch of a more lopsided win in Woonsocket Saturday by the home team, the Mount Saint Charles 15-only team traveled&hellip;</div><a class="related-read-more href="https://www.hockeyjournal.com/analysis-strong-performers-in-mount-st-charles-vs-cape-cod-whalers-15o-game/">Read More</a></div></div></main></div></div><div class="sm-ad-box footer-ad-slot"><!-- BEGIN ADVERTSERVE CODE -->
<div id="dRXRcfNWDGxEGQUHnHHdeh">
<script type="text/javascript">
var _avp = _avp || [];
_avp.push({ tagid: 'dRXRcfNWDGxEGQUHnHHdeh', alias: '/', type: 'banner', zid: 6, pid: 0, secure: true });
</script>
</div>
<!-- END ADVERTSERVE CODE --></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="media_image-2" class="widget widget_media_image"><div class="widget-wrap"><img width="1954" height="631" src="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png" class="image wp-image-197  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1.png 1954w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-300x97.png 300w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-768x248.png 768w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-1024x331.png 1024w, https://www.hockeyjournal.com/wp-content/uploads/sites/2/2018/04/NEHockey-Journal_white-1-600x194.png 600w" sizes="(max-width: 1954px) 100vw, 1954px" /></div></section>
<section id="nav_menu-4" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-social-icons-menu-container"><ul id="menu-social-icons-menu" class="menu"><li id="menu-item-26" class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-26"><a target="_blank" rel="noopener" href="https://twitter.com/NEHockeyJournal"><i class="fa fa-twitter-square" aria-hidden="true"></i></a></li>
<li id="menu-item-25" class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-25"><a target="_blank" rel="noopener" href="https://Facebook.com/HockeyJournal"><i class="fa fa-facebook-square" aria-hidden="true"></i></a></li>
<li id="menu-item-71006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71006"><a href="https://www.instagram.com/newenglandhockeyjournal/"><i class="fa fa-instagram" aria-hidden="true"</i></i></a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Our Free Weekly Newsletter</h4>
			<div class="textwidget"><p><a href="/newsletter/"><button>Sign Up</button></a></p>
</div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-terms-menu-container"><ul id="menu-footer-terms-menu" class="menu"><li id="menu-item-535" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-535"><a href="https://www.hockeyjournal.com/subscribe/">Subscribe</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21"><a href="https://www.seamansmedia.com/">Seamans Media, Inc.</a></li>
<li id="menu-item-1189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1189"><a href="https://www.hockeyjournal.com/privacy-policy-notice/">Privacy</a></li>
<li id="menu-item-1059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1059"><a href="https://www.hockeyjournal.com/contact/">Contact Us</a></li>
</ul></div></div></section>
<section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-social-icons-menu-container"><ul id="menu-social-icons-menu-1" class="menu"><li class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-26"><a target="_blank" rel="noopener" href="https://twitter.com/NEHockeyJournal"><i class="fa fa-twitter-square" aria-hidden="true"></i></a></li>
<li class="social-icon menu-item menu-item-type-custom menu-item-object-custom menu-item-25"><a target="_blank" rel="noopener" href="https://Facebook.com/HockeyJournal"><i class="fa fa-facebook-square" aria-hidden="true"></i></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71006"><a href="https://www.instagram.com/newenglandhockeyjournal/"><i class="fa fa-instagram" aria-hidden="true"</i></i></a></li>
</ul></div></div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>© Copyright 2021 Seamans Media, Inc. • All Rights Reserved </p></div></footer></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" style="bottom:15px;right:65px;background-color:transparent;"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fanalysis-early-awards-and-key-performances-of-2006-forwards%2F&amp;linkname=Analysis%3A%20Early%20awards%20and%20key%20performances%20of%202006%20forwards" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fanalysis-early-awards-and-key-performances-of-2006-forwards%2F&amp;linkname=Analysis%3A%20Early%20awards%20and%20key%20performances%20of%202006%20forwards" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.hockeyjournal.com%2Fanalysis-early-awards-and-key-performances-of-2006-forwards%2F&amp;linkname=Analysis%3A%20Early%20awards%20and%20key%20performances%20of%202006%20forwards" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div><div id="pum-378" class="pum pum-overlay pum-theme-376 pum-theme-default-theme popmake-overlay click_open" data-popmake="{&quot;id&quot;:378,&quot;slug&quot;:&quot;contact&quot;,&quot;theme_id&quot;:376,&quot;cookies&quot;:[],&quot;triggers&quot;:[{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:false,&quot;responsive_min_width&quot;:false,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:false,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:false,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:false,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:false,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:false,&quot;position_left&quot;:false,&quot;position_bottom&quot;:false,&quot;position_right&quot;:false,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:false,&quot;animation_speed&quot;:false,&quot;animation_origin&quot;:false,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:false},&quot;close&quot;:{&quot;text&quot;:false,&quot;button_delay&quot;:false,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_378">

	<div id="popmake-378" class="pum-container popmake theme-376 pum-responsive pum-responsive-medium responsive size-medium">

				

				            <div id="pum_popup_title_378" class="pum-title popmake-title">
				Contact Us!			</div>
		

		

				<div class="pum-content popmake-content" tabindex="0">
			<p>Please write a brief description and someone will get back to you shortly!<br />
<script type="text/javascript"></script>
                <div class='gf_browser_unknown gform_wrapper gform_legacy_markup_wrapper' id='gform_wrapper_2' ><form method='post' enctype='multipart/form-data'  id='gform_2'  action='/analysis-early-awards-and-key-performances-of-2006-forwards/' > 
 <input type='hidden' class='gforms-pum' value='{"closepopup":false,"closedelay":0,"openpopup":false,"openpopup_id":0}' />
                        <div class='gform_body gform-body'><ul id='gform_fields_2' class='gform_fields top_label form_sublabel_below description_below'><li id="field_2_1" class="gfield gf-nofield-label gfield_contains_required field_sublabel_above field_description_above gfield_visibility_visible" ><label class='gfield_label gfield_label_before_complex'  >Name<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_complex ginput_container no_prefix has_first_name no_middle_name has_last_name no_suffix gf_name_has_2 ginput_container_name' id='input_2_1'>
                            
                            <span id='input_2_1_3_container' class='name_first' >
                                                    <label for='input_2_1_3' >First</label>
                                                    <input type='text' name='input_1.3' id='input_2_1_3' value='' aria-label='First name'   aria-required='true'   placeholder='First Name'  />
                                                </span>
                            
                            <span id='input_2_1_6_container' class='name_last' >
                                                            <label for='input_2_1_6' >Last</label>
                                                            <input type='text' name='input_1.6' id='input_2_1_6' value='' aria-label='Last name'   aria-required='true'   placeholder='Last Name'  />
                                                        </span>
                            
                        </div></li><li id="field_2_3" class="gfield gf-nofield-label gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label' for='input_2_3' >Email<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_3' id='input_2_3' type='text' value='' class='large'   placeholder='Email Address' aria-required="true" aria-invalid="false"  />
                        </div></li><li id="field_2_4" class="gfield field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label screen-reader-text' for='input_2_4' ></label><div id='input_2_4' class='ginput_container ginput_recaptcha' data-sitekey='6Le_ZsIZAAAAAFJXN5UBjhaauMogPPmGQ9eKYIwj'  data-theme='light' data-tabindex='-1' data-size='invisible' data-badge='bottomright'></div></li><li id="field_2_2" class="gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label' for='input_2_2' >Brief Description<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_textarea'><textarea name='input_2' id='input_2_2' class='textarea large'     aria-required="true" aria-invalid="false"   rows='10' cols='50'></textarea></div></li><li id="field_2_5" class="gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible" ><label class='gfield_label' for='input_2_5' >Phone</label><div class='ginput_container'><input name='input_5' id='input_2_5' type='text' value='' /></div><div class='gfield_description' id='gfield_description_2_5'>This field is for validation purposes and should be left unchanged.</div></li></ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_2' class='gform_button button' value='Submit'  onclick='if(window["gf_submitting_2"]){return false;}  window["gf_submitting_2"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_2"]){return false;} window["gf_submitting_2"]=true;  jQuery("#gform_2").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_2' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='2' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_2' value='WyJbXSIsIjlmYWRiZjA5NjczMjgzNWE1NDQ3NzA2NjAxYjYyNjIwIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_2' id='gform_target_page_number_2' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_2' id='gform_source_page_number_2' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        <p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="106"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>
                        </div></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			&#215;            </button>
		
	</div>

</div>
	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/superside-me/includes/js/sidr.me.min.js?ver=2.2.1' id='supersideme-sidr-js'></script>
<script type='text/javascript' id='superside-init-js-extra'>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</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/superside-me/includes/js/supersideme.min.js?ver=2.7.3' id='superside-init-js'></script>
<script type='text/javascript' id='fue-front-script-js-extra'>
/* <![CDATA[ */
var FUE_Front = {"is_logged_in":"","ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce-follow-up-emails/templates/js/fue-front.js?ver=4.9.15' id='fue-front-script-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.5.7.1' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.hockeyjournal.com\/checkout\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=5.7.1' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.5.7.1' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=5.7.1' id='woocommerce-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-content/themes/seamans-sports/js/global.js?ver=1.4' id='global-js-js'></script>
<script type='text/javascript' defer='defer' src='https://www.hockeyjournal.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.5.12' id='gform_placeholder-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' id='popup-maker-site-js-extra'>
/* <![CDATA[ */
var pum_vars = {"version":"1.16.2","pm_dir_url":"https:\/\/www.hockeyjournal.com\/wp-content\/plugins\/popup-maker\/","ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","restapi":"https:\/\/www.hockeyjournal.com\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"376","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[],"analytics_route":"analytics","analytics_api":"https:\/\/www.hockeyjournal.com\/wp-json\/pum\/v1"};
var pum_sub_vars = {"ajaxurl":"https:\/\/www.hockeyjournal.com\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-378":{"triggers":[],"cookies":[],"disable_on_mobile":false,"disable_on_tablet":false,"atc_promotion":null,"explain":null,"type_section":null,"theme_id":376,"size":"medium","responsive_min_width":"0%","responsive_max_width":"100%","custom_width":"640px","custom_height_auto":false,"custom_height":"380px","scrollable_content":false,"animation_type":"fade","animation_speed":350,"animation_origin":"center top","open_sound":"none","custom_sound":"","location":"center top","position_top":100,"position_bottom":0,"position_left":0,"position_right":0,"position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"zindex":1999999999,"close_button_delay":0,"fi_promotion":null,"close_on_form_submission":false,"close_on_form_submission_delay":0,"close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"default-theme","id":378,"slug":"contact"}};
/* ]]> */
</script>
<script type='text/javascript' src='//www.hockeyjournal.com/wp-content/uploads/sites/2/pum/pum-site-scripts-2.js?defer&#038;generated=1625775951&#038;ver=1.16.2' id='popup-maker-site-js'></script>
<script type='text/javascript' src='https://www.hockeyjournal.com/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<!-- WooCommerce JavaScript -->
<script type="text/javascript">
jQuery(function($) { 

			$( '.add_to_cart_button:not(.product_type_variable, .product_type_grouped)' ).on( 'click', function() {
				ga('send', 'event', 'Products', 'Add to Cart', ($(this).data('product_sku')) ? ($(this).data('product_sku')) : ('#' + $(this).data('product_id')));
			});
		

ga( 'send', 'pageview' ); 
 });
</script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 2) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [2, 1]) } );
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.hockeyjournal.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body></html>
